redsn0w Can Jailbreak iOS 5 Beta 3

As confirmed by @MuscleNerd via Twitter, developers looking to jailbreak iOS 5 Beta 3 (released today) can do so with redsn0w using the same version released a few weeks ago.

MuscleNerd notes:

Today’s 5.0b3 can be jailbroken with last month’s redsn0w http://is.gd/6eek4Y(point it at 5.0b1 IPSW..devs only please!)

As long as you still have the iOS 5 Beta 1 firmware file, you’re good to go!

Thanks MuscleNerd and the entire iPhone Dev Team for their hard work!

Reports on iPhone news, reviews apps and accessories. Also an armed ninja with an iPhone 4S.

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Kemak

    Why do I need the beta 1 firmware ? Can’t I just update to beta3 from beta2 custom firmware created with sn0wbreeze?

  • Rio

    You can update using iTunes it self, but in order for RedSnow to Jailbreak your beta 3 you need to point it to the beta 1 ipsw

  • Rio

    You can update using iTunes it self, but in order for RedSnow to Jailbreak your beta 3 you need to point it to the beta 1 ipsw

  • Rio

    You can update using iTunes it self, but in order for RedSnow to Jailbreak your beta 3 you need to point it to the beta 1 ipsw

  • Rio

    You can update using iTunes it self, but in order for RedSnow to Jailbreak your beta 3 you need to point it to the beta 1 ipsw

  • Rio

    You can update using iTunes it self, but in order for RedSnow to Jailbreak your beta 3 you need to point it to the beta 1 ipsw