Quantcast

redsn0w 0.9.10b1, PwnageTool 5.0.1 Downloads for iOS 5.0.1 Untethered Jailbreak [Update]

Update 2: The iPhone Dev team has released an update to redsn0w, version 0.9.10b3:

Update #3: The b3 version of redsn0w fixes a problem where re-running redsn0w over an existing jailbreak would cause MobileSubstrate-based apps to stop running until MS was installed again.  Now you can re-run the redsn0w jailbreak step without worrying about that (but still remember to de-select the “Install Cydia” option if it’s already installed).
TIP: If auto-detection fails and redsn0w tells you no identifying data was found, you can always pre-select the appropriate 5.0.1 IPSW using “Extras->Select IPSW”.
Here are the redsn0w download links:
===

Update 1: The iPhone Dev Team has released an update to redsn0w, version 0.9.10b2:

Update #2: The b2 version of redsn0w includes the launchctl-related fix by @planetbeing as mentioned by @saurik here and here.  As usual, you can just re-run redsn0w in jailbreak mode over your existing 5.0.1 jailbreak (even a PwnageTool one), making sure to de-select “Install Cydia” if you do.  Always be sure to do a controlled “slide to power off” shutdown of your device before running redsn0w.
Here are the redsn0w download links:

The iPhone Dev Team also received pod2g’s iOS 5.0.1 untethered jailbreak to package, test and distribute. That has arrived in the form of an updated version of redsn0w 0.9.10b1. The iPhone Dev Team also notes a few things to keep in mind regarding this untether:

  • The untether is for iOS 5.0.1 on iPhone3GS, iPhone4, iPhone4-CDMA, iPad1, iPod touch 3G, iPod touch 4G
  • If you have one of those devices and are not on 5.0.1 yet, update now!  The SHSH window is still open for 5.0.1  If you unlock via ultrasn0w or gevey, make sure you only get to 5.0.1 via a custom IPSW!  Once you’re at 5.0.1, use the latest redsn0w 0.9.10 to both jailbreak and untether.
  • If you’re already at 5.0.1 with a tethered jailbreak, you have two choices: either run redsn0w 0.9.10 over your current jailbreak (deselect “Install Cydia” if you do that), or install the Cydia package prepared by the chronic devteam.  The patches are the same regardless of which you choose.
  • Some of you are using a hybrid 5.0/5.0.1 configuration.  If so, do not attempt to install this untether over that setup!  You will most likely get into a reboot cycle.  Do a sync and fresh restore to 5.0.1 then install the jailbreak + untether.

What Does This All Mean?

If you don’t care about an unlock via ultrasn0w, update your A4 devices to iOS 5.0.1 via iTunes and jailbreak via redsn0w 09.10b1 (here’s a similar guide to follow in the meantime):

If you require the ultrasn0w unlock, update to iOS 5.0.1 via a custom firmware (to preserve your baseband) by using PwnageTool 5.0.1 (here’s a similar guide to follow).

Already on a tethered iOS 5.0.1 jailbreak? Run the latest redsn0w 0.9.10 over your existing tethered jailbreak to untether. Or, even easier just download and install ‘Corona’ in Cydia, released by the Chronic Dev Team.

Let us know how your untethered jailbreaks go!

Founder and Editor-in-Chief of iPhoneinCanada.ca. Follow me on Twitter, and @iPhoneinCanada, and on Google+.

  • Jbohn

    I’m confused… so much at once here. What route do you go if you’re a first-timer looking to jailbreak and unlock?

  • http://www.iphoneincanada.ca Gary

    Update to iOS 5.0.1 via PwnageTool.

  • Jbohn

    But I’m already on 5.0.1

  • Ash

    What is a 5.0/5.0.1 configuration? I am already jailbroken but I can’t find out any information as to what this type of configuration is.

  • Jbohn

    I guess there is no unlock option for those already on 5.0.1 :(

  • Mabinju Gasa

    So if your baseband was updated to 4.11.08 then you can still jailbreak and install cydia however you cannot unlock to use with other carriers like tmobile. Can someone confirm this please..

  • hellasbaby

    When will your release jailbreak for the iPad 2? ive been waiting for that

  • Mabinju Gasa

    Go  to Setting->General->About-> then scroll all the way down and you will see your modem firmware. I am not sure what you mean by configuration of ios 5.0/5.0.1…………………
    Your baseband will determine whether you can unlock to use with other carriers

  • Ash

    Thanks but this question has nothing to do with unlocking to use other carriers. I am wondering if I can update to untethered by Cydia or if I have to restore via iTunes and then re-jailbreak my phone.

  • dean

    i cant seem to get cydia to work right.  it tries to install its files and says it will exit when its done but it doesnt.  the screen just turns black and it doesnt do anything from there.

  • http://www.iphoneincanada.ca Gary

    Yes update in Cydia to untethered.

  • http://www.iphoneincanada.ca Gary

    Pod2g is working on the A5 jailbreak right now.

  • http://www.iphoneincanada.ca Gary

    Then you’re unable to unlock if your baseband is not one of the ones listed in ultrasn0w.

  • hellasbaby

    I hope they finish it by new year’s. It would be the best gift.

  • Ash

     It may be possible that I have 5.0/5.0.1 semi tethered jailbreak right now and it states above:

    “Some of you are using a hybrid 5.0/5.0.1 configuration.  If so, do not
    attempt to install this untether over that setup!  You will most likely
    get into a reboot cycle.  Do a sync and fresh restore to 5.0.1 then
    install the jailbreak + untether.”

    I just want to know what that is, just in case I do have that configuration.

  • Britney

     I have jailbroken my iPhone but it won’t let me use WinterBoard at all now and I can’t find XBackup, a cydia app I bought before I restored my iPhone to backup my apps. What do I do??

  • Britney

     I can’t even change my root password to my phone which puts me at risk as well. I am about to just restore and use my phone as a non jailbroken phone and I am regretting restoring from my semi-tethered settings. I had my phone exactly as I liked it. Even now, when I turn my phone off, it stays stuck on the Apple logo until I re-jailbreak it. I am very disappointed so far.

  • Frazer

    Any word on when we can jailbreak a 4S yet?! Ughhh!!!!

  • Pedped

    If im on tethered 5.0 can I follow this even though its for 5.0.1? will it still work?

  • http://www.iphoneincanada.ca Gary

    There was a semi-tether released a while back. If you used it, restore to 5.0.1 first then use redsn0w.

  • http://www.iphoneincanada.ca Gary

    Update to 5.0.1.

  • Me.

    Do i just update to 5.0.1 directly from iTunes or have to download the iOS 5.0.1 firmware prior using redsnow?

  • http://twitter.com/fred_math Frédéric Mathieu

    Yep. I suppose you have an iPhone 4. Then, ultrasn0w only unlocks baseband 01.59.00 on iPhone 4, so you are unfortunately out of luck. You can still enjoy your jailbreak on 5.0.1.

  • http://www.iphoneincanada.ca Gary

    If you don’t care about unlocking download via iTunes.

  • http://www.iphoneincanada.ca Gary

    Pod2g is working on it as we speak.

  • Soccermagic0

    Cydia says theres an error that can not be automatically fixed and then wont FU**ing install anything.

  • Kraken

    Redsnow has been updated to B2.

  • Kirk

    Ran my jailbreak… Installed…. Worked flawless. +1 for the jailbreak community… I guess I could say I’m back…only thing I’m waiting for with this really is a ultra snow unlock. I had already upgraded my baseband unfortunately so can’t do it yet.

  • http://twitter.com/fred_math Frédéric Mathieu

    Gary, seems like Redsn0w has the same feature of PwnageTool, that is to create a custom firmware to preserve the baseband. So people on Windows looking to unlock on 5.0.1 can do it too. Just a heads-up for your post!

  • Kool2cue

    Hi all
    HELP ADVISE. I have old original factory unlocked iPhone 4 Jailbroken with ultrasn0w to 4.3.3. Want to go to iOS 5 without loosing any Apps and associated data. What do I do use the redsn0w untethered now out?? Do I backup and unlock via ultrasn0w or what?? Help please!

  • Gamercyrus

    Quick question, can anyone help?

    I just jailbreak’ed with redsn0w, version 0.9.10b1 a few days ago. My question is would I have to reinstall all my JB apps and settings if I upgrade to version 0.9.10b3???

    That’s a lot work I hope to advoid.

    Thanks!

  • http://www.iphoneincanada.ca Gary

    No. Just run redsn0w again but untick ‘Install Cydia’.

  • Gamercyrus

    Awesome thanks! Good cuz I just got everything set the way I want it.

  • casper088

    hi i wanted to ask that if my ipod came with a hybrid 5.0.1 howdo i jailbreak it because wen i tried it with red snow, on reboot, the ipod turns on and redsnow just stays on rebooting 

  • Angie

    I’m stuck in ” waiting for reboot” my ipod already reboot and went to the lock screen. What should I do? I have an Ipod Touch 4G iOS 5.0.1